[RPG] MineQuest-Citizens 2.0.0 [CB 1.4.6-R0.1]

Discussion in 'Bukkit Plugins' started by robxu9, Jul 23, 2012.

  1. Gottor Starting Out

    Another problem :) When I run the server on my computer, everything works fine, but when I upload to the hosting server, then I can not accept the quest from the NPC by pressing the left mouse button or right.
  2. robxu9 Head Developer

    Be careful with that; NPC ids may not be the same between servers. :/
  3. ningyou Starting Out

    Any idea when the gui will be working again?
    I just got this and can't seem to figure out how to make the quest start when I click the npc :/ I'm trying to use the quest helper but it's very confusing
  4. robxu9 Head Developer

    No idea if I can get the GUI stuff going again. I'll have to take a look at it when I have time.
  5. ningyou Starting Out

    Alright, but could you help me with how to make it so you can choose to start a quest by clicking the npc?
  6. robxu9 Head Developer

    Instructions are on the initial post.
  7. tastyquest Starting Out

  8. robxu9 Head Developer

    Sorry for the long wait, everyone!
    Downloads are now at jci.lincomlinux.org.

    Please note that this is following current MineQuest development builds, 1.4.5-R0.2 and the latest Citizens2 Dev, so make sure to upgrade!

    On another note, if you have Denizens, I'm adding the /quest admingive command to the latest MineQuest development builds, if you want your Denizens to give quests!
  9. Vincent1468 Starting Out

    Is it possible that you can assign a quest-npc only to 1 permissions group?
  10. robxu9 Head Developer

    No; I haven't made that possible yet.
  11. Vincent1468 Starting Out

    Do you think you are going to add that?
  12. robxu9 Head Developer

    I would recommend using Denizens with the /quest admingive command for now.
    Their work is much more maintained than this plugin.
  13. Pixel_maniax Starting Out

    I'll give feedback as soon as I'll have tried it out. It sounds very good...
    Thanks for all you work.

    Keep it up!
  14. mewetea119 Starting Out

    I dont uderstand.. when i type /mqnpc it says 'unknown command'.. i have citizens 2.0 2.0.6 and minequest 2.0... what am i missing. ?
  15. Vincent1468 Starting Out

    Did you also install minequest-citizens?
    Echobob likes this.
  16. mewetea119 Starting Out

    actually i didnt at that time. but now i do. was able to assign the npc to give quests with /mqnpc toggle 'id' and edit the config for that npc.. and still after reboot server i get nothing when i go up to the npc and try to start a quest.
  17. mewetea119 Starting Out

    can anyone help me? I have citizens 2. citizens-quest and minequest. trying to get my npc to issue a quest when u approach him. Cant see to get it to work. here is my quest: http://pastebin.com/DQpZPPcb
  18. Vincent1468 Starting Out

    you still need to assign the NPC to a player with /mqnpc assign [NPCID] [target]
    if i want to assign a npc with the ID 1 to notch i would type this:
    /mqnpc assign 1 Notch

    Maybe they should add a feature where every player can use the npc quest that you dont have to assign them all. or is that already possible?
  19. mewetea119 Starting Out

    wow thats silly.. i didnt know that.. that allmost seems pointless then.
  20. Alexander Starting Out

    When i install "wireless redstone" i have this problem....
    Error occurred while enabling MineQuest-Citizens vunofficialDev (Is it up to date?)
    java.lang.ExceptionInInitializerError
    at net.teamio.minequest.citizens.MQAddonCitizens.onEnable(MQAddonCitizens.java:78)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.loadPlugin(CraftServer.java:282)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.enablePlugins(CraftServer.java:264)
    at net.minecraft.server.v1_4_6.MinecraftServer.j(MinecraftServer.java:321)
    at net.minecraft.server.v1_4_6.MinecraftServer.e(MinecraftServer.java:300)
    at net.minecraft.server.v1_4_6.MinecraftServer.a(MinecraftServer.java:259)
    at net.minecraft.server.v1_4_6.DedicatedServer.init(DedicatedServer.java:149)
    at net.minecraft.server.v1_4_6.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.v1_4_6.ThreadServerApplication.run(SourceFile:849)
    Caused by: java.lang.NullPointerException
    at net.teamio.minequest.citizens.tracker.DescriptionManager.<clinit>(DescriptionManager.java:36)
    ... 12 more

    what can i do? THX U :p